re = /(?:[ ]{4,}|\t{1,})(.+)/m
str = 'This is a code block:
There are four spaces
before each line
testing
How about a code fence?
``` xojo
This must have three backticks
flanking it
```
I love `inline code` too
and more code blocks:
Don\'t you?
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end