import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<unit_type>SF)(?P<unit_size>500|400|350|300|250|200|150|125)(?P<mounting_type>A|B|K)(?P<decompression_feature>0|1)(?P<sep_1>-)(?P<cracking_pressure>1)(?P<sep_2>-)(?P<unit_series>4X)(?P<sep_3>/)(?P<type_of_limit_switch>Q2|)(?P<power_supply_of_limit_switch>G24Z|)(?P<seal_material>|)(?P<pipe_port>|)(?P<special_version>SO102|SO104|)(?P<additional_details>(.|[0-9])*)$";
final String string = "SF200A1-1-4X/\n"
+ "SF250A1-1-4X/\n"
+ "SF400A1-1-4X/\n"
+ "SF200K0-1-4X/\n"
+ "SF150A1-1-4X/\n"
+ "SF125B1-1-4X/\n"
+ "SF125A1-1-4X/\n"
+ "SF200B1-1-4X/\n"
+ "SF150B1-1-4X/\n"
+ "SF250B1-1-4X/\n"
+ "SF250A0-1-4X/\n"
+ "SF150A0-1-4X/\n"
+ "SF300A1-1-4X/\n"
+ "SF200K0-1-4X/SO72\n"
+ "SF125A0-1-4X/\n"
+ "SF300A0-1-4X/\n"
+ "SF300B1-1-4X/\n"
+ "SF350A0-1-4X/\n"
+ "SF250K0-1-4X/\n"
+ "SF200A0-1-4X/\n"
+ "SF150K0-1-4X/\n"
+ "SF125B0-1-4X/\n"
+ "SF150B0-1-4X/\n"
+ "SF200B0-1-4X/\n"
+ "SF350A1-1-4X/\n"
+ "SF500A1-1-4X/\n"
+ "SF150K0-1-4X/SO72\n"
+ "SF125K0-1-4X/\n"
+ "SF400A0-1-4X/\n"
+ "SF250B0-1-4X/\n"
+ "SF350B1-1-4X/\n"
+ "SF300K0-1-4X/\n"
+ "SF250K0-1-4X/SO72\n"
+ "SF300K0-1-4X/SO72\n"
+ "SF300B0-1-4X/\n"
+ "SF250B1-1-4X/SO103\n"
+ "SF125K0-1-4X/V\n"
+ "SF125B1-1-4X/SO103\n"
+ "SF400B1-1-4X/\n"
+ "SF125A1-1-4X/SO103\n"
+ "SF200A1-1-4X/SO103\n"
+ "SF150B1-1-4X/V\n"
+ "SF250A1-1-4X/SO103\n"
+ "SF150B1-1-4X/SO103\n"
+ "SF200K0-1-4X/SO103\n"
+ "SF300K0-1-4X/V\n"
+ "SF350B0-1-4X/\n"
+ "SF150A0-1-4X/V\n"
+ "SF150A1-1-4X/SO103\n"
+ "SF150A0-1-4X/Q2G24\n"
+ "SF200A0-1-4X/Q2G24\n"
+ "SF250A0-1-4X/Q2G24\n"
+ "SF300A0-1-4X/Q2G24\n"
+ "SF400A0-1-4X/Q2G24\n"
+ "SF500B1-1-4X/\n"
+ "SF125A0-1-4X/Q2G24\n"
+ "SF250A0-1-4X/V\n"
+ "SF350A0-1-4X/Q2G24\n"
+ "SF350A1-1-4X/V\n"
+ "SF125A1-1-4X/V\n"
+ "SF500A0-1-4X/Q2G24\n"
+ "SF125A0-1-4X/Q2G24SO103\n"
+ "SF250K0-1-4X/SO92\n"
+ "SF200B1-1-4X/SO103\n"
+ "SF150B0-1-4X/500\n"
+ "SF150A0-1-4X/500\n"
+ "SF200B0-1-4X/500\n"
+ "SF200A0-1-4X/500\n"
+ "SF250B0-1-4X/500\n"
+ "SF250A0-1-4X/500\n"
+ "SF300A0-1-4X/500\n"
+ "SF300B0-1-4X/500\n"
+ "SF500A1-1-4X/Q2G24\n"
+ "SF200A0-1-4X/500Q2G24\n"
+ "SF300A0-1-4X/500Q2G24\n"
+ "SF400B0-1-4X/\n"
+ "SF400A1-1-4X/Q2G24\n"
+ "SF250A0-1-4X/SO43A1840\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}