// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?P<unit_type>SF)(?P<unit_size>500|400|350|300|250|200|150|125)(?P<mounting_type>A|B|K)(?P<decompression_feature>0|1)(?P<sep_1>-)(?P<cracking_pressure>1)(?P<sep_2>-)(?P<unit_series>4X)(?P<sep_3>/)(?P<type_of_limit_switch>Q2|)(?P<power_supply_of_limit_switch>G24Z|)(?P<seal_material>|)(?P<pipe_port>|)(?P<special_version>SO102|SO104|)(?P<additional_details>(.|[0-9])*)$").unwrap();
let string = "SF200A1-1-4X/
SF250A1-1-4X/
SF400A1-1-4X/
SF200K0-1-4X/
SF150A1-1-4X/
SF125B1-1-4X/
SF125A1-1-4X/
SF200B1-1-4X/
SF150B1-1-4X/
SF250B1-1-4X/
SF250A0-1-4X/
SF150A0-1-4X/
SF300A1-1-4X/
SF200K0-1-4X/SO72
SF125A0-1-4X/
SF300A0-1-4X/
SF300B1-1-4X/
SF350A0-1-4X/
SF250K0-1-4X/
SF200A0-1-4X/
SF150K0-1-4X/
SF125B0-1-4X/
SF150B0-1-4X/
SF200B0-1-4X/
SF350A1-1-4X/
SF500A1-1-4X/
SF150K0-1-4X/SO72
SF125K0-1-4X/
SF400A0-1-4X/
SF250B0-1-4X/
SF350B1-1-4X/
SF300K0-1-4X/
SF250K0-1-4X/SO72
SF300K0-1-4X/SO72
SF300B0-1-4X/
SF250B1-1-4X/SO103
SF125K0-1-4X/V
SF125B1-1-4X/SO103
SF400B1-1-4X/
SF125A1-1-4X/SO103
SF200A1-1-4X/SO103
SF150B1-1-4X/V
SF250A1-1-4X/SO103
SF150B1-1-4X/SO103
SF200K0-1-4X/SO103
SF300K0-1-4X/V
SF350B0-1-4X/
SF150A0-1-4X/V
SF150A1-1-4X/SO103
SF150A0-1-4X/Q2G24
SF200A0-1-4X/Q2G24
SF250A0-1-4X/Q2G24
SF300A0-1-4X/Q2G24
SF400A0-1-4X/Q2G24
SF500B1-1-4X/
SF125A0-1-4X/Q2G24
SF250A0-1-4X/V
SF350A0-1-4X/Q2G24
SF350A1-1-4X/V
SF125A1-1-4X/V
SF500A0-1-4X/Q2G24
SF125A0-1-4X/Q2G24SO103
SF250K0-1-4X/SO92
SF200B1-1-4X/SO103
SF150B0-1-4X/500
SF150A0-1-4X/500
SF200B0-1-4X/500
SF200A0-1-4X/500
SF250B0-1-4X/500
SF250A0-1-4X/500
SF300A0-1-4X/500
SF300B0-1-4X/500
SF500A1-1-4X/Q2G24
SF200A0-1-4X/500Q2G24
SF300A0-1-4X/500Q2G24
SF400B0-1-4X/
SF400A1-1-4X/Q2G24
SF250A0-1-4X/SO43A1840
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}