package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)"(?:[^"\\]|\\.)*"`)
var str = `"a \" b"
"a \
b"
"a string with \\\" double slash at the end\\"
"\\"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}