re = /(?s)"(?:[^"\\]|\\.)*"/
str = '"a \\" b"
"a \\
b"
"a string with \\\\\\" double slash at the end\\\\"
"\\\\"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end