// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"jdbc:postgresql:\/\/127\.0\.0\.1\/redseal|jdbc:postgresql:\/\/localhost\/redseal").unwrap();
let string = "jdbc:postgresql://127.0.0.1/redseal
jdbc:postgresql://localhost/redseal";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}