const regex = /^(?:music|pictures)\/tom((?:\/(?:[\w-]+(?:[ ]+[\w-]+)*))*)(\/(?:[\w-]+(?:[ ]+[\w-]+)*))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:music|pictures)\\\/tom((?:\\\/(?:[\\w-]+(?:[ ]+[\\w-]+)*))*)(\\\/(?:[\\w-]+(?:[ ]+[\\w-]+)*))$', 'gm')
const str = `music/tom/foldername
music/tom/folder name
music/tom/abc/foldername/folder2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}