re = /^(?:music|pictures)\/tom((?:\/(?:[\w-]+(?:[ ]+[\w-]+)*))*)(\/(?:[\w-]+(?:[ ]+[\w-]+)*))$/m
str = 'music/tom/foldername
music/tom/folder name
music/tom/abc/foldername/folder2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end