#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:Version:\s)(.*)"
Local $sString = "Package: magma" & @CRLF & _
"Priority: extra" & @CRLF & _
"Section: default" & @CRLF & _
"Installed-Size: 90236" & @CRLF & _
"Maintainer: <admin@ip-192-168-61-194>" & @CRLF & _
"Architecture: amd64" & @CRLF & _
"Replaces: magma" & @CRLF & _
"Provides: magma" & @CRLF & _
"Version: 0.3.75-1563950165-a44a8468" & @CRLF & _
"Filename: pool/main/m/magma/magma-0.3.75-1563950165-a44a8468.deb" & @CRLF & _
"Size: 26511912" & @CRLF & _
"MD5sum: 0d4d62c2019a4982e2ade51e5bfc2c1a" & @CRLF & _
"SHA1: e06c607604aa5e51f09e3278e0ee8768e4850687" & @CRLF & _
"SHA256: 07bb69f9495f9f400f23094fad1836cae81c4c4e389e067d652cee284f21a217" & @CRLF & _
"SHA512: b4ce4d121db6d49aa78025813484fa136949df10d9bd108a26b8e658e9aa457b9ff7cb5b1f036789ba9531e3583c5f3047d08727e1be4ec6fd795e487e4f9a54" & @CRLF & _
"Description: Magma Access Gateway" & @CRLF & _
"Homepage: http://example.com/no-uri-given" & @CRLF & _
"Vendor: admin@ip-192-168-61-194" & @CRLF & _
"License: unknown" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")