import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:Version:\\s)(.*)";
final String string = "Package: magma\n"
+ "Priority: extra\n"
+ "Section: default\n"
+ "Installed-Size: 90236\n"
+ "Maintainer: <admin@ip-192-168-61-194>\n"
+ "Architecture: amd64\n"
+ "Replaces: magma\n"
+ "Provides: magma\n"
+ "Version: 0.3.75-1563950165-a44a8468\n"
+ "Filename: pool/main/m/magma/magma-0.3.75-1563950165-a44a8468.deb\n"
+ "Size: 26511912\n"
+ "MD5sum: 0d4d62c2019a4982e2ade51e5bfc2c1a\n"
+ "SHA1: e06c607604aa5e51f09e3278e0ee8768e4850687\n"
+ "SHA256: 07bb69f9495f9f400f23094fad1836cae81c4c4e389e067d652cee284f21a217\n"
+ "SHA512: b4ce4d121db6d49aa78025813484fa136949df10d9bd108a26b8e658e9aa457b9ff7cb5b1f036789ba9531e3583c5f3047d08727e1be4ec6fd795e487e4f9a54\n"
+ "Description: Magma Access Gateway\n"
+ "Homepage: http://example.com/no-uri-given\n"
+ "Vendor: admin@ip-192-168-61-194\n"
+ "License: unknown\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}