// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:Version:\s)(.*)").unwrap();
let string = "Package: magma
Priority: extra
Section: default
Installed-Size: 90236
Maintainer: <admin@ip-192-168-61-194>
Architecture: amd64
Replaces: magma
Provides: magma
Version: 0.3.75-1563950165-a44a8468
Filename: pool/main/m/magma/magma-0.3.75-1563950165-a44a8468.deb
Size: 26511912
MD5sum: 0d4d62c2019a4982e2ade51e5bfc2c1a
SHA1: e06c607604aa5e51f09e3278e0ee8768e4850687
SHA256: 07bb69f9495f9f400f23094fad1836cae81c4c4e389e067d652cee284f21a217
SHA512: b4ce4d121db6d49aa78025813484fa136949df10d9bd108a26b8e658e9aa457b9ff7cb5b1f036789ba9531e3583c5f3047d08727e1be4ec6fd795e487e4f9a54
Description: Magma Access Gateway
Homepage: http://example.com/no-uri-given
Vendor: admin@ip-192-168-61-194
License: unknown
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}