re = /[?]\s?/
str = 'Hi. How are you? What time is it? Beep?'
subst = '?\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result