package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d{1,6}\s\w+\s\w+\s[A-Za-z]{2},\s([A-Za-z]+),\s[A-Za-z]{2}(,\s\d{1,6}|\s\d{1,6})`)
var str = `717 N 2ND ST, MANKATO, MN 56001
717 N 2ND ST, MANKATO, MN, 560010`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}