import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{1,6}\\s\\w+\\s\\w+\\s[A-Za-z]{2},\\s([A-Za-z]+),\\s[A-Za-z]{2}(,\\s\\d{1,6}|\\s\\d{1,6})";
final String string = "717 N 2ND ST, MANKATO, MN 56001\n"
+ "717 N 2ND ST, MANKATO, MN, 560010";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}