const regex = new RegExp('\\d{1,6}\\s\\w+\\s\\w+\\s[A-Za-z]{2},\\s([A-Za-z]+),\\s[A-Za-z]{2}(,\\s\\d{1,6}|\\s\\d{1,6})', 'g')
const str = `717 N 2ND ST, MANKATO, MN 56001
717 N 2ND ST, MANKATO, MN, 560010`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}