const regex = /(?<=[a-zA-Z])(?=[A-Z])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[a-zA-Z])(?=[A-Z])', 'g')
const str = `thisIsACamelCaseString`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);