re = /(?<=[a-zA-Z])(?=[A-Z])/
str = 'thisIsACamelCaseString'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result