import re
regex = re.compile(r"(?<=[a-zA-Z])(?=[A-Z])")
test_str = "thisIsACamelCaseString"
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)