using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\('.*?',\s*('.*?:.*?').*?\)";
string input = @"test1:testVar('varName', 'ns2:test')
test2:testVar('varName', 'ns2:test', 'defValue')
test2:testVar('varName', 'ns2:test', 'defValue') = test2:testVar('varName', 'ns1:test111', 'defValue') ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}