re = /\('.*?',\s*('.*?:.*?').*?\)/
str = 'test1:testVar(\'varName\', \'ns2:test\')
test2:testVar(\'varName\', \'ns2:test\', \'defValue\')
test2:testVar(\'varName\', \'ns2:test\', \'defValue\') = test2:testVar(\'varName\', \'ns1:test111\', \'defValue\') '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end