#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(#[^#><]*#)(?=[^>]*<\/cfquery>)"
Local $sString = "<cfquery datasource="#tablename#">" & @CRLF & _
" SELECT * FROM table WHERE name = #test# and #test2#;" & @CRLF & _
"</cfquery>"
Local $sSubst = "<cfqueryparam value="$1" />"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)