import Foundation
let pattern = ##"(#[^#><]*#)(?=[^>]*<\/cfquery>)"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
<cfquery datasource="#tablename#">
SELECT * FROM table WHERE name = #test# and #test2#;
</cfquery>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<cfqueryparam value="$1" />"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)