$re = '/(#[^#><]*#)(?=[^>]*<\/cfquery>)/';
$str = '<cfquery datasource="#tablename#">
SELECT * FROM table WHERE name = #test# and #test2#;
</cfquery>';
$subst = "<cfqueryparam value=\"$1\" />";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;