const regex = /(?!\.)(\d+(\.\d+)+)(?:[-.][A-Z]+)?(?![\d.])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!\\.)(\\d+(\\.\\d+)+)(?:[-.][A-Z]+)?(?![\\d.])$', 'gm')
const str = `1.0.0-SNAPSHOT
1.0.0.RC
1.0.0-RELEASE
1.0.0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}