re = /(?!\.)(\d+(\.\d+)+)(?:[-.][A-Z]+)?(?![\d.])$/m
str = '1.0.0-SNAPSHOT
1.0.0.RC
1.0.0-RELEASE
1.0.0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end