$re = '/(?!\.)(\d+(\.\d+)+)(?:[-.][A-Z]+)?(?![\d.])$/m';
$str = '1.0.0-SNAPSHOT
1.0.0.RC
1.0.0-RELEASE
1.0.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);