package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.+?)(?:\..+)?`)
var str = `company
deriv.x
isConfirmed.y`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}