const regex = /(.+?)(?:\..+)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.+?)(?:\\..+)?', 'gm')
const str = `company
deriv.x
isConfirmed.y`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);