$re = '/(.+?)(?:\..+)?/m';
$str = 'company
deriv.x
isConfirmed.y';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;