import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{LOOP:(\\w+)[^\\}]*\\}((\\s*?.?)*?)\\{\\/LOOP:\\1\\}";
final String string = "<tbody>\n"
+ " {LOOP:MENU}\n"
+ " <tr>\n"
+ " <td>{VAR:ID}</td>\n"
+ " <td>{VAR:NAME}</td>\n"
+ " <td>{VAR:ROLLE}</td>\n"
+ " <td>{VAR:ACTIONS}</td>\n"
+ " </tr>\n"
+ " {/LOOP:MENU}\n"
+ "</tbody>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}