const regex = /\{LOOP:(\w+)[^}]*\}((\s*?.?)*?)\{\/LOOP:\1\}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{LOOP:(\\w+)[^}]*\\}((\\s*?.?)*?)\\{\\\/LOOP:\\1\\}', '')
const str = `<tbody>
{LOOP:MENU}
<tr>
<td>{VAR:ID}</td>
<td>{VAR:NAME}</td>
<td>{VAR:ROLLE}</td>
<td>{VAR:ACTIONS}</td>
</tr>
{/LOOP:MENU}
</tbody>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}