re = /\{LOOP:(\w+)[^}]*\}((\s*?.?)*?)\{\/LOOP:\1\}/
str = '<tbody>
{LOOP:MENU}
<tr>
<td>{VAR:ID}</td>
<td>{VAR:NAME}</td>
<td>{VAR:ROLLE}</td>
<td>{VAR:ACTIONS}</td>
</tr>
{/LOOP:MENU}
</tbody>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end