using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([#.a-z]{1}[a-z_]{1}[\s\S]+?){([\s\S]*?)}";
string substitution = @"$1";
string input = @".test {}
._test {
test: tesdff;
test1: tesdff;
test2: tesdff;
}
aaa {
test1: tesdff;
test2: tesdff;
}
#test {}
#test1 {}
#_test {}
#_test,
#test2 {}
#_test:psudo-class {}
#1 {}
.2 {}
.- {}
##test {}
..test {}
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}