re = /([#.a-z]{1}[a-z_]{1}[\s\S]+?){([\s\S]*?)}/
str = '.test {}
._test {
test: tesdff;
test1: tesdff;
test2: tesdff;
}
aaa {
test1: tesdff;
test2: tesdff;
}
#test {}
#test1 {}
#_test {}
#_test,
#test2 {}
#_test:psudo-class {}
#1 {}
.2 {}
.- {}
##test {}
..test {}
'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result