const regex = /([#.a-z]{1}[a-z_]{1}[\s\S]+?){([\s\S]*?)}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([#.a-z]{1}[a-z_]{1}[\\s\\S]+?){([\\s\\S]*?)}', 'g')
const str = `.test {}
._test {
test: tesdff;
test1: tesdff;
test2: tesdff;
}
aaa {
test1: tesdff;
test2: tesdff;
}
#test {}
#test1 {}
#_test {}
#_test,
#test2 {}
#_test:psudo-class {}
#1 {}
.2 {}
.- {}
##test {}
..test {}
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);