#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<div id="pageContent">[\s\S]*<div id="pageContent">"
Local $sString = " "HTML Tidy for Mac OS X (vers 31 October 2006 - Apple Inc. build 15.15), see www.w3.org">" & @CRLF & _
"" & @CRLF & _
" <title>02.00: Page 1</title>" & @CRLF & _
" <meta charset="utf-8">" & @CRLF & _
" <script type="text/javascript">" & @CRLF & _
"var pg_csslibs = []; // CSS Libs for this Page" & @CRLF & _
" var pg_jslibs = []; // JS Libs for this Page" & @CRLF & _
" </script>" & @CRLF & _
" <script src="../../global/js/settings.js" id="settingJS" type=" & @CRLF & _
" "text/javascript">" & @CRLF & _
"</script>" & @CRLF & _
"</head>" & @CRLF & _
"" & @CRLF & _
"<body>" & @CRLF & _
" <div id="pageContent">" & @CRLF & _
" <!-- CONTENT GOES HERE -->" & @CRLF & _
"" & @CRLF & _
" <div id="pageContent">" & @CRLF & _
" <div>" & @CRLF & _
" <p><a href="pop/02_00_01/02_00_01_pop01.htm" class=" & @CRLF & _
" "modal-pop"><strong>Print</strong></a> the Carousel of Progress" & @CRLF & _
" Checklist provided below to keep track of your progress" & @CRLF & _
" through the <span class="lang" data-term=" & @CRLF & _
" "module_name">module</span>. It is important that you read" & @CRLF & _
" each page and complete all practice activities in every" & @CRLF & _
" <span class="lang" data-term="lesson_name"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")