const regex = /<div id="pageContent">[\s\S]*<div id="pageContent">/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<div id="pageContent">[\\s\\S]*<div id="pageContent">', '')
const str = ` "HTML Tidy for Mac OS X (vers 31 October 2006 - Apple Inc. build 15.15), see www.w3.org">
<title>02.00: Page 1</title>
<meta charset="utf-8">
<script type="text/javascript">
var pg_csslibs = []; // CSS Libs for this Page
var pg_jslibs = []; // JS Libs for this Page
</script>
<script src="../../global/js/settings.js" id="settingJS" type=
"text/javascript">
</script>
</head>
<body>
<div id="pageContent">
<!-- CONTENT GOES HERE -->
<div id="pageContent">
<div>
<p><a href="pop/02_00_01/02_00_01_pop01.htm" class=
"modal-pop"><strong>Print</strong></a> the Carousel of Progress
Checklist provided below to keep track of your progress
through the <span class="lang" data-term=
"module_name">module</span>. It is important that you read
each page and complete all practice activities in every
<span class="lang" data-term="lesson_name`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}