import re
regex = re.compile(r"<div id=\"pageContent\">[\s\S]*<div id=\"pageContent\">")
test_str = (" \"HTML Tidy for Mac OS X (vers 31 October 2006 - Apple Inc. build 15.15), see www.w3.org\">\n\n"
" <title>02.00: Page 1</title>\n"
" <meta charset=\"utf-8\">\n"
" <script type=\"text/javascript\">\n"
"var pg_csslibs = []; // CSS Libs for this Page\n"
" var pg_jslibs = []; // JS Libs for this Page\n"
" </script>\n"
" <script src=\"../../global/js/settings.js\" id=\"settingJS\" type=\n"
" \"text/javascript\">\n"
"</script>\n"
"</head>\n\n"
"<body>\n"
" <div id=\"pageContent\">\n"
" <!-- CONTENT GOES HERE -->\n\n"
" <div id=\"pageContent\">\n"
" <div>\n"
" <p><a href=\"pop/02_00_01/02_00_01_pop01.htm\" class=\n"
" \"modal-pop\"><strong>Print</strong></a> the Carousel of Progress\n"
" Checklist provided below to keep track of your progress\n"
" through the <span class=\"lang\" data-term=\n"
" \"module_name\">module</span>. It is important that you read\n"
" each page and complete all practice activities in every\n"
" <span class=\"lang\" data-term=\"lesson_name")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")