package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\-]?\d*[\.]?[\d]*$`)
var str = `0.23455465
4.54656
-334343
-.34234234
234234.4234234
23123
323-312312
-12121.34344
asdasd
2312
213.3213.3213`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}