import re
regex = re.compile(r"^[\-]?\d*[\.]?[\d]*$", flags=re.MULTILINE)
test_str = ("0.23455465\n"
"4.54656\n"
"-334343\n"
"-.34234234\n"
"234234.4234234\n"
"23123\n"
"323-312312\n"
"-12121.34344\n"
"asdasd\n"
"2312\n"
"213.3213.3213")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")