use strict;
my $str = '0.23455465
4.54656
-334343
-.34234234
234234.4234234
23123
323-312312
-12121.34344
asdasd
2312
213.3213.3213';
my $regex = qr/^[\-]?\d*[\.]?[\d]*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}