#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?iUms)(?=^\s+Drive\s+at\s+Enclosure\s+(\d+),\s+Slot\s+(\d+)).*(Status)\s?+:(.*)$"
Local $sString = "DRIVES------------------------------" & @CRLF & _
"" & @CRLF & _
"SUMMARY" & @CRLF & _
" Number of drives: 96" & @CRLF & _
" Current media type(s): Hard Disk Drive (96)" & @CRLF & _
" Current interface type(s): Fibre (96)" & @CRLF & _
"" & @CRLF & _
" BASIC:" & @CRLF & _
"" & @CRLF & _
" ENCLOSURE, SLOT STATUS CAPACITY MEDIA TYPE INTERFACE TYPE CURRENT DATA RATE PRODUCT ID FIRMWARE VERSION CAPABILITIES " & @CRLF & _
" 0, 1 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 0, 2 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 0, 3 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 0, 4 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 0, 5 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 0, 6 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 0, 7 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 0, 8 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH00 " & @CRLF & _
" 0, 9 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 0, 10 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 0, 11 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 0, 12 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 0, 13 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 0, 14 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 0, 15 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 0, 16 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH00 " & @CRLF & _
" 1, 1 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 1, 2 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 1, 3 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 1, 4 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A2 " & @CRLF & _
" 1, 5 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 1, 6 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 1, 7 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 1, 8 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 1, 9 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 1, 10 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 1, 11 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 1, 12 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 1, 13 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 1, 14 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 1, 15 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 1, 16 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 2, 1 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 2, 2 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 2, 3 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 2, 4 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 2, 5 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 2, 6 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 2, 7 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 2, 8 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 2, 9 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 2, 10 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 2, 11 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 2, 12 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 2, 13 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH00 " & @CRLF & _
" 2, 14 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 2, 15 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 2, 16 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 3, 1 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 3, 2 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 3, 3 Impending failure (reported by drive) 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 3, 4 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 3, 5 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 3, 6 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 3, 7 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 3, 8 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 3, 9 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 3, 10 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 3, 11 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 3, 12 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 3, 13 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 3, 14 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 3, 15 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 3, 16 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 4, 1 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 4, 2 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 4, 3 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 4, 4 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 4, 5 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 4, 6 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 4, 7 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 4, 8 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 4, 9 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 4, 10 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 4, 11 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 4, 12 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 4, 13 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 4, 14 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 4, 15 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 4, 16 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 5, 1 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 5, 2 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 5, 3 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 5, 4 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 " & @CRLF & _
" 5, 5 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 5, 6 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A2 " & @CRLF & _
" 5, 7 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 5, 8 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 5, 9 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 5, 10 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 5, 11 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 5, 12 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 5, 13 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 5, 14 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 5, 15 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
" 5, 16 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 " & @CRLF & _
"" & @CRLF & _
" DRIVE CHANNELS:" & @CRLF & _
"" & @CRLF & _
" ENCLOSURE, SLOT PREFERRED CHANNEL REDUNDANT CHANNEL " & @CRLF & _
" 0, 1 1 5 " & @CRLF & _
" 0, 2 5 1 " & @CRLF & _
" 0, 3 1 5 " & @CRLF & _
" 0, 4 5 1 " & @CRLF & _
" 0, 5 1 5 " & @CRLF & _
" 0, 6 5 1 " & @CRLF & _
" 0, 7 1 5 " & @CRLF & _
" 0, 8 5 1 " & @CRLF & _
" 0, 9 1 5 " & @CRLF & _
" 0, 10 5 1 " & @CRLF & _
" 0, 11 1 5 " & @CRLF & _
" 0, 12 5 1 " & @CRLF & _
" 0, 13 1 5 " & @CRLF & _
" 0, 14 5 1 " & @CRLF & _
" 0, 15 1 5 " & @CRLF & _
" 0, 16 5 1 " & @CRLF & _
" 1, 1 1 5 " & @CRLF & _
" 1, 2 5 1 " & @CRLF & _
" 1, 3 1 5 " & @CRLF & _
" 1, 4 5 1 " & @CRLF & _
" 1, 5 1 5 " & @CRLF & _
" 1, 6 5 1 " & @CRLF & _
" 1, 7 1 5 " & @CRLF & _
" 1, 8 5 1 " & @CRLF & _
" 1, 9 1 5 " & @CRLF & _
" 1, 10 5 1 " & @CRLF & _
" 1, 11 1 5 " & @CRLF & _
" 1, 12 5 1 " & @CRLF & _
" 1, 13 1 5 " & @CRLF & _
" 1, 14 5 1 " & @CRLF & _
" 1, 15 1 5 " & @CRLF & _
" 1, 16 5 1 " & @CRLF & _
" 2, 1 2 6 " & @CRLF & _
" 2, 2 6 2 " & @CRLF & _
" 2, 3 2 6 " & @CRLF & _
" 2, 4 6 2 " & @CRLF & _
" 2, 5 2 6 " & @CRLF & _
" 2, 6 6 2 " & @CRLF & _
" 2, 7 2 6 " & @CRLF & _
" 2, 8 6 2 " & @CRLF & _
" 2, 9 2 6 " & @CRLF & _
" 2, 10 6 2 " & @CRLF & _
" 2, 11 2 6 " & @CRLF & _
" 2, 12 6 2 " & @CRLF & _
" 2, 13 2 6 " & @CRLF & _
" 2, 14 6 2 " & @CRLF & _
" 2, 15 2 6 " & @CRLF & _
" 2, 16 6 2 " & @CRLF & _
" 3, 1 2 6 " & @CRLF & _
" 3, 2 6 2 " & @CRLF & _
" 3, 3 2 6 " & @CRLF & _
" 3, 4 6 2 " & @CRLF & _
" 3, 5 2 6 " & @CRLF & _
" 3, 6 6 2 " & @CRLF & _
" 3, 7 2 6 " & @CRLF & _
" 3, 8 6 2 " & @CRLF & _
" 3, 9 2 6 " & @CRLF & _
" 3, 10 6 2 " & @CRLF & _
" 3, 11 2 6 " & @CRLF & _
" 3, 12 6 2 " & @CRLF & _
" 3, 13 2 6 " & @CRLF & _
" 3, 14 6 2 " & @CRLF & _
" 3, 15 2 6 " & @CRLF & _
" 3, 16 6 2 " & @CRLF & _
" 4, 1 3 7 " & @CRLF & _
" 4, 2 7 3 " & @CRLF & _
" 4, 3 3 7 " & @CRLF & _
" 4, 4 7 3 " & @CRLF & _
" 4, 5 3 7 " & @CRLF & _
" 4, 6 7 3 " & @CRLF & _
" 4, 7 3 7 " & @CRLF & _
" 4, 8 7 3 " & @CRLF & _
" 4, 9 3 7 " & @CRLF & _
" 4, 10 7 3 " & @CRLF & _
" 4, 11 3 7 " & @CRLF & _
" 4, 12 7 3 " & @CRLF & _
" 4, 13 3 7 " & @CRLF & _
" 4, 14 7 3 " & @CRLF & _
" 4, 15 3 7 " & @CRLF & _
" 4, 16 7 3 " & @CRLF & _
" 5, 1 4 8 " & @CRLF & _
" 5, 2 8 4 " & @CRLF & _
" 5, 3 4 8 " & @CRLF & _
" 5, 4 8 4 " & @CRLF & _
" 5, 5 4 8 " & @CRLF & _
" 5, 6 8 4 " & @CRLF & _
" 5, 7 4 8 " & @CRLF & _
" 5, 8 8 4 " & @CRLF & _
" 5, 9 4 8 " & @CRLF & _
" 5, 10 8 4 " & @CRLF & _
" 5, 11 4 8 " & @CRLF & _
" 5, 12 8 4 " & @CRLF & _
" 5, 13 4 8 " & @CRLF & _
" 5, 14 8 4 " & @CRLF & _
" 5, 15 4 8 " & @CRLF & _
" 5, 16 8 4 " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"HOT SPARE COVERAGE:" & @CRLF & _
" The following arrays are not protected: None - All arrays are protected" & @CRLF & _
" Total hot spare drives: 3" & @CRLF & _
"" & @CRLF & _
" Standby: 3 " & @CRLF & _
" In use: 0 " & @CRLF & _
"" & @CRLF & _
" Standby drive at enclosure 5, slot 16 (Fibre, 558.912 GB)" & @CRLF & _
" Protects the following arrays: RG3, RG1, RG2, RG4, RG5, RG6, RG7, RG8" & @CRLF & _
"" & @CRLF & _
" Standby drive at enclosure 2, slot 11 (Fibre, 558.912 GB)" & @CRLF & _
" Protects the following arrays: RG3, RG1, RG2, RG4, RG5, RG6, RG7, RG8" & @CRLF & _
"" & @CRLF & _
" Standby drive at enclosure 1, slot 16 (Fibre, 558.912 GB)" & @CRLF & _
" Protects the following arrays: RG3, RG1, RG2, RG4, RG5, RG6, RG7, RG8" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" DETAILS" & @CRLF & _
" Drive at Enclosure 0, Slot 1" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" Status: Optimal " & @CRLF & _
" " & @CRLF & _
" Mode: Assigned " & @CRLF & _
" Raw capacity: 558.912 GB " & @CRLF & _
" Usable capacity: 558.412 GB " & @CRLF & _
" World-wide identifier: 20:00:b4:52:53:57:b6:25:00:00:00:00:00:00:00:00 " & @CRLF & _
" Associated array: RG1 " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" Port Channel ID " & @CRLF & _
" 0 1 0/0xEF " & @CRLF & _
" 1 5 0/0xEF " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" Media type: Hard Disk Drive " & @CRLF & _
" Interface type: Fibre Channel " & @CRLF & _
" Drive path redundancy: OK " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" Security Capable: No " & @CRLF & _
" Secure: No " & @CRLF & _
" Read/write accessible: Yes " & @CRLF & _
" Drive security key identifier: Not Applicable " & @CRLF & _
" " & @CRLF & _
" Speed: 15,000 RPM " & @CRLF & _
" Current data rate: 4 Gbps " & @CRLF & _
" Product ID: ST3600057FC F " & @CRLF & _
" Drive Firmware Version: B9A4 " & @CRLF & _
" Serial number: 6SL1BP4T0000B147KZ7T " & @CRLF & _
" Manufacturer: IBM-SSG " & @CRLF & _
" Date of manufacture: 2011 Jul 4 " & @CRLF & _
"" & @CRLF & _
" Drive at Enclosure 0, Slot 2" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" Status: Optimal " & @CRLF & _
" " & @CRLF & _
" Mode: Assigned " & @CRLF & _
" Raw capacity: 558.912 GB " & @CRLF & _
" Usable capacity: 558.412 GB " & @CRLF & _
" World-wide identifier: 20:00:b4:52:53:ab:ae:74:00:00:00:00:00:00:00:00 " & @CRLF & _
" Associated array: RG1 " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" Port Channel ID " & @CRLF & _
" 0 5 1/0xE8 " & @CRLF & _
" 1 1 1/0xE8 " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" Media type: Hard Disk Drive " & @CRLF & _
" Interface type: Fibre Channel " & @CRLF & _
" Drive path redundancy: OK " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" Security Capable: No " & @CRLF & _
" Secure: No " & @CRLF & _
" Read/write accessible: Yes " & @CRLF & _
" Drive security key identifier: Not Applicable " & @CRLF & _
" " & @CRLF & _
" Speed: 15,000 RPM " & @CRLF & _
" Current data rate: 4 Gbps " & @CRLF & _
" Product ID: ST3600057FC F " & @CRLF & _
" Drive Firmware Version: B9A4 " & @CRLF & _
" Serial number: 6SL7YS8L0000B4250CDP " & @CRLF & _
" Manufacturer: IBM-SSG " & @CRLF & _
" Date of manufacture: 2014 Feb 10 " & @CRLF & _
"" & @CRLF & _
" Drive at Enclosure 0, Slot 3" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" Status: Optimal " & @CRLF & _
" " & @CRLF & _
" Mode: Assigned " & @CRLF & _
" Raw capacity: 558.912 GB " & @CRLF & _
" Usable capacity: 558.412 GB " & @CRLF & _
" World-wide identifier: 20:00:b4:52:53:5a:35:0d:00:00:00:00:00:00:00:00 " & @CRLF & _
" Associated array: RG1 " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" Port Channel ID " & @CRLF & _
" 0 1 2/0xE4 " & @CRLF & _
" 1 5 2/0xE4 " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" Media type: Hard Disk Drive " & @CRLF & _
" Interface type: Fibre Channel " & @CRLF & _
" Drive path redundancy: OK " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" Security Capable: No " & @CRLF & _
" Secure: No " & @CRLF & _
" Read/write accessible: Yes " & @CRLF & _
" Drive security key identifier: Not Applicable " & @CRLF & _
" " & @CRLF & _
" Speed: 15,000 RPM " & @CRLF & _
" Current data rate: 4 Gbps " & @CRLF & _
" Product ID: ST3600057FC F " & @CRLF & _
" Drive Firmware Version: B9A4 " & @CRLF & _
" Serial number: 6SL1HTM50000B148Q5BN " & @CRLF & _
" Manufacturer: IBM-SSG " & @CRLF & _
" Date of manufacture: 2011 Jul 16 " & @CRLF & _
"" & @CRLF & _
" Drive at Enclosure 0, Slot 4" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" Status: Optimal " & @CRLF & _
" " & @CRLF & _
" Mode: Assigned " & @CRLF & _
" Raw capacity: 558.912 GB " & @CRLF & _
" Usable capacity: 558.412 GB " & @CRLF & _
" World-wide identifier: 20:00:b4:52:53:57:b5:db:00:00:00:00:00:00:00:00 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")