import re
regex = re.compile(r"(?=^\s+Drive\s+at\s+Enclosure\s+(\d+),\s+Slot\s+(\d+)).*(Status)\s?+:(.*)$", flags=re.IGNORECASE | re.MULTILINE | re.DOTALL)
test_str = ("DRIVES------------------------------\n\n"
"SUMMARY\n"
" Number of drives: 96\n"
" Current media type(s): Hard Disk Drive (96)\n"
" Current interface type(s): Fibre (96)\n\n"
" BASIC:\n\n"
" ENCLOSURE, SLOT STATUS CAPACITY MEDIA TYPE INTERFACE TYPE CURRENT DATA RATE PRODUCT ID FIRMWARE VERSION CAPABILITIES \n"
" 0, 1 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 0, 2 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 0, 3 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 0, 4 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 0, 5 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 0, 6 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 0, 7 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 0, 8 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH00 \n"
" 0, 9 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 0, 10 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 0, 11 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 0, 12 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 0, 13 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 0, 14 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 0, 15 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 0, 16 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH00 \n"
" 1, 1 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 1, 2 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 1, 3 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 1, 4 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A2 \n"
" 1, 5 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 1, 6 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 1, 7 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 1, 8 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 1, 9 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 1, 10 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 1, 11 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 1, 12 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 1, 13 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 1, 14 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 1, 15 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 1, 16 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 2, 1 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 2, 2 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 2, 3 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 2, 4 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 2, 5 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 2, 6 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 2, 7 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 2, 8 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 2, 9 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 2, 10 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 2, 11 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 2, 12 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 2, 13 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH00 \n"
" 2, 14 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 2, 15 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 2, 16 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 3, 1 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 3, 2 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 3, 3 Impending failure (reported by drive) 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 3, 4 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 3, 5 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 3, 6 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 3, 7 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 3, 8 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 3, 9 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 3, 10 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 3, 11 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 3, 12 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 3, 13 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 3, 14 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 3, 15 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 3, 16 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 4, 1 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 4, 2 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 4, 3 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 4, 4 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 4, 5 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 4, 6 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 4, 7 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 4, 8 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 4, 9 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 4, 10 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 4, 11 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 4, 12 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 4, 13 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 4, 14 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 4, 15 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 4, 16 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 5, 1 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 5, 2 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 5, 3 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 5, 4 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02 \n"
" 5, 5 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 5, 6 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A2 \n"
" 5, 7 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 5, 8 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 5, 9 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 5, 10 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 5, 11 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 5, 12 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 5, 13 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 5, 14 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 5, 15 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n"
" 5, 16 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4 \n\n"
" DRIVE CHANNELS:\n\n"
" ENCLOSURE, SLOT PREFERRED CHANNEL REDUNDANT CHANNEL \n"
" 0, 1 1 5 \n"
" 0, 2 5 1 \n"
" 0, 3 1 5 \n"
" 0, 4 5 1 \n"
" 0, 5 1 5 \n"
" 0, 6 5 1 \n"
" 0, 7 1 5 \n"
" 0, 8 5 1 \n"
" 0, 9 1 5 \n"
" 0, 10 5 1 \n"
" 0, 11 1 5 \n"
" 0, 12 5 1 \n"
" 0, 13 1 5 \n"
" 0, 14 5 1 \n"
" 0, 15 1 5 \n"
" 0, 16 5 1 \n"
" 1, 1 1 5 \n"
" 1, 2 5 1 \n"
" 1, 3 1 5 \n"
" 1, 4 5 1 \n"
" 1, 5 1 5 \n"
" 1, 6 5 1 \n"
" 1, 7 1 5 \n"
" 1, 8 5 1 \n"
" 1, 9 1 5 \n"
" 1, 10 5 1 \n"
" 1, 11 1 5 \n"
" 1, 12 5 1 \n"
" 1, 13 1 5 \n"
" 1, 14 5 1 \n"
" 1, 15 1 5 \n"
" 1, 16 5 1 \n"
" 2, 1 2 6 \n"
" 2, 2 6 2 \n"
" 2, 3 2 6 \n"
" 2, 4 6 2 \n"
" 2, 5 2 6 \n"
" 2, 6 6 2 \n"
" 2, 7 2 6 \n"
" 2, 8 6 2 \n"
" 2, 9 2 6 \n"
" 2, 10 6 2 \n"
" 2, 11 2 6 \n"
" 2, 12 6 2 \n"
" 2, 13 2 6 \n"
" 2, 14 6 2 \n"
" 2, 15 2 6 \n"
" 2, 16 6 2 \n"
" 3, 1 2 6 \n"
" 3, 2 6 2 \n"
" 3, 3 2 6 \n"
" 3, 4 6 2 \n"
" 3, 5 2 6 \n"
" 3, 6 6 2 \n"
" 3, 7 2 6 \n"
" 3, 8 6 2 \n"
" 3, 9 2 6 \n"
" 3, 10 6 2 \n"
" 3, 11 2 6 \n"
" 3, 12 6 2 \n"
" 3, 13 2 6 \n"
" 3, 14 6 2 \n"
" 3, 15 2 6 \n"
" 3, 16 6 2 \n"
" 4, 1 3 7 \n"
" 4, 2 7 3 \n"
" 4, 3 3 7 \n"
" 4, 4 7 3 \n"
" 4, 5 3 7 \n"
" 4, 6 7 3 \n"
" 4, 7 3 7 \n"
" 4, 8 7 3 \n"
" 4, 9 3 7 \n"
" 4, 10 7 3 \n"
" 4, 11 3 7 \n"
" 4, 12 7 3 \n"
" 4, 13 3 7 \n"
" 4, 14 7 3 \n"
" 4, 15 3 7 \n"
" 4, 16 7 3 \n"
" 5, 1 4 8 \n"
" 5, 2 8 4 \n"
" 5, 3 4 8 \n"
" 5, 4 8 4 \n"
" 5, 5 4 8 \n"
" 5, 6 8 4 \n"
" 5, 7 4 8 \n"
" 5, 8 8 4 \n"
" 5, 9 4 8 \n"
" 5, 10 8 4 \n"
" 5, 11 4 8 \n"
" 5, 12 8 4 \n"
" 5, 13 4 8 \n"
" 5, 14 8 4 \n"
" 5, 15 4 8 \n"
" 5, 16 8 4 \n\n\n"
"HOT SPARE COVERAGE:\n"
" The following arrays are not protected: None - All arrays are protected\n"
" Total hot spare drives: 3\n\n"
" Standby: 3 \n"
" In use: 0 \n\n"
" Standby drive at enclosure 5, slot 16 (Fibre, 558.912 GB)\n"
" Protects the following arrays: RG3, RG1, RG2, RG4, RG5, RG6, RG7, RG8\n\n"
" Standby drive at enclosure 2, slot 11 (Fibre, 558.912 GB)\n"
" Protects the following arrays: RG3, RG1, RG2, RG4, RG5, RG6, RG7, RG8\n\n"
" Standby drive at enclosure 1, slot 16 (Fibre, 558.912 GB)\n"
" Protects the following arrays: RG3, RG1, RG2, RG4, RG5, RG6, RG7, RG8\n\n\n"
" DETAILS\n"
" Drive at Enclosure 0, Slot 1\n"
" \n\n"
" Status: Optimal \n"
" \n"
" Mode: Assigned \n"
" Raw capacity: 558.912 GB \n"
" Usable capacity: 558.412 GB \n"
" World-wide identifier: 20:00:b4:52:53:57:b6:25:00:00:00:00:00:00:00:00 \n"
" Associated array: RG1 \n\n\n"
" Port Channel ID \n"
" 0 1 0/0xEF \n"
" 1 5 0/0xEF \n\n\n"
" Media type: Hard Disk Drive \n"
" Interface type: Fibre Channel \n"
" Drive path redundancy: OK \n"
" \n"
" \n"
" Security Capable: No \n"
" Secure: No \n"
" Read/write accessible: Yes \n"
" Drive security key identifier: Not Applicable \n"
" \n"
" Speed: 15,000 RPM \n"
" Current data rate: 4 Gbps \n"
" Product ID: ST3600057FC F \n"
" Drive Firmware Version: B9A4 \n"
" Serial number: 6SL1BP4T0000B147KZ7T \n"
" Manufacturer: IBM-SSG \n"
" Date of manufacture: 2011 Jul 4 \n\n"
" Drive at Enclosure 0, Slot 2\n"
" \n\n"
" Status: Optimal \n"
" \n"
" Mode: Assigned \n"
" Raw capacity: 558.912 GB \n"
" Usable capacity: 558.412 GB \n"
" World-wide identifier: 20:00:b4:52:53:ab:ae:74:00:00:00:00:00:00:00:00 \n"
" Associated array: RG1 \n\n\n"
" Port Channel ID \n"
" 0 5 1/0xE8 \n"
" 1 1 1/0xE8 \n\n\n"
" Media type: Hard Disk Drive \n"
" Interface type: Fibre Channel \n"
" Drive path redundancy: OK \n"
" \n"
" \n"
" Security Capable: No \n"
" Secure: No \n"
" Read/write accessible: Yes \n"
" Drive security key identifier: Not Applicable \n"
" \n"
" Speed: 15,000 RPM \n"
" Current data rate: 4 Gbps \n"
" Product ID: ST3600057FC F \n"
" Drive Firmware Version: B9A4 \n"
" Serial number: 6SL7YS8L0000B4250CDP \n"
" Manufacturer: IBM-SSG \n"
" Date of manufacture: 2014 Feb 10 \n\n"
" Drive at Enclosure 0, Slot 3\n"
" \n\n"
" Status: Optimal \n"
" \n"
" Mode: Assigned \n"
" Raw capacity: 558.912 GB \n"
" Usable capacity: 558.412 GB \n"
" World-wide identifier: 20:00:b4:52:53:5a:35:0d:00:00:00:00:00:00:00:00 \n"
" Associated array: RG1 \n\n\n"
" Port Channel ID \n"
" 0 1 2/0xE4 \n"
" 1 5 2/0xE4 \n\n\n"
" Media type: Hard Disk Drive \n"
" Interface type: Fibre Channel \n"
" Drive path redundancy: OK \n"
" \n"
" \n"
" Security Capable: No \n"
" Secure: No \n"
" Read/write accessible: Yes \n"
" Drive security key identifier: Not Applicable \n"
" \n"
" Speed: 15,000 RPM \n"
" Current data rate: 4 Gbps \n"
" Product ID: ST3600057FC F \n"
" Drive Firmware Version: B9A4 \n"
" Serial number: 6SL1HTM50000B148Q5BN \n"
" Manufacturer: IBM-SSG \n"
" Date of manufacture: 2011 Jul 16 \n\n"
" Drive at Enclosure 0, Slot 4\n"
" \n\n"
" Status: Optimal \n"
" \n"
" Mode: Assigned \n"
" Raw capacity: 558.912 GB \n"
" Usable capacity: 558.412 GB \n"
" World-wide identifier: 20:00:b4:52:53:57:b5:db:00:00:00:00:00:00:00:00 ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")