re = /(?=^\s+Drive\s+at\s+Enclosure\s+(\d+),\s+Slot\s+(\d+)).*(Status)\s?+:(.*)$/im
str = 'DRIVES------------------------------
SUMMARY
Number of drives: 96
Current media type(s): Hard Disk Drive (96)
Current interface type(s): Fibre (96)
BASIC:
ENCLOSURE, SLOT STATUS CAPACITY MEDIA TYPE INTERFACE TYPE CURRENT DATA RATE PRODUCT ID FIRMWARE VERSION CAPABILITIES
0, 1 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
0, 2 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
0, 3 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
0, 4 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
0, 5 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
0, 6 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
0, 7 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
0, 8 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH00
0, 9 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
0, 10 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
0, 11 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
0, 12 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
0, 13 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
0, 14 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
0, 15 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
0, 16 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH00
1, 1 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
1, 2 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
1, 3 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
1, 4 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A2
1, 5 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
1, 6 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
1, 7 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
1, 8 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
1, 9 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
1, 10 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
1, 11 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
1, 12 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
1, 13 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
1, 14 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
1, 15 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
1, 16 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
2, 1 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
2, 2 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
2, 3 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
2, 4 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
2, 5 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
2, 6 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
2, 7 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
2, 8 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
2, 9 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
2, 10 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
2, 11 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
2, 12 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
2, 13 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH00
2, 14 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
2, 15 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
2, 16 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
3, 1 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
3, 2 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
3, 3 Impending failure (reported by drive) 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
3, 4 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
3, 5 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
3, 6 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
3, 7 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
3, 8 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
3, 9 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
3, 10 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
3, 11 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
3, 12 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
3, 13 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
3, 14 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
3, 15 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
3, 16 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
4, 1 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
4, 2 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
4, 3 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
4, 4 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
4, 5 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
4, 6 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
4, 7 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
4, 8 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
4, 9 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
4, 10 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
4, 11 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
4, 12 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
4, 13 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
4, 14 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
4, 15 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
4, 16 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
5, 1 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
5, 2 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
5, 3 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
5, 4 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps HUS1560600FC F JH02
5, 5 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
5, 6 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A2
5, 7 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
5, 8 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
5, 9 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
5, 10 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
5, 11 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
5, 12 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
5, 13 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
5, 14 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
5, 15 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
5, 16 Optimal 558.912 GB Hard Disk Drive Fibre 4 Gbps ST3600057FC F B9A4
DRIVE CHANNELS:
ENCLOSURE, SLOT PREFERRED CHANNEL REDUNDANT CHANNEL
0, 1 1 5
0, 2 5 1
0, 3 1 5
0, 4 5 1
0, 5 1 5
0, 6 5 1
0, 7 1 5
0, 8 5 1
0, 9 1 5
0, 10 5 1
0, 11 1 5
0, 12 5 1
0, 13 1 5
0, 14 5 1
0, 15 1 5
0, 16 5 1
1, 1 1 5
1, 2 5 1
1, 3 1 5
1, 4 5 1
1, 5 1 5
1, 6 5 1
1, 7 1 5
1, 8 5 1
1, 9 1 5
1, 10 5 1
1, 11 1 5
1, 12 5 1
1, 13 1 5
1, 14 5 1
1, 15 1 5
1, 16 5 1
2, 1 2 6
2, 2 6 2
2, 3 2 6
2, 4 6 2
2, 5 2 6
2, 6 6 2
2, 7 2 6
2, 8 6 2
2, 9 2 6
2, 10 6 2
2, 11 2 6
2, 12 6 2
2, 13 2 6
2, 14 6 2
2, 15 2 6
2, 16 6 2
3, 1 2 6
3, 2 6 2
3, 3 2 6
3, 4 6 2
3, 5 2 6
3, 6 6 2
3, 7 2 6
3, 8 6 2
3, 9 2 6
3, 10 6 2
3, 11 2 6
3, 12 6 2
3, 13 2 6
3, 14 6 2
3, 15 2 6
3, 16 6 2
4, 1 3 7
4, 2 7 3
4, 3 3 7
4, 4 7 3
4, 5 3 7
4, 6 7 3
4, 7 3 7
4, 8 7 3
4, 9 3 7
4, 10 7 3
4, 11 3 7
4, 12 7 3
4, 13 3 7
4, 14 7 3
4, 15 3 7
4, 16 7 3
5, 1 4 8
5, 2 8 4
5, 3 4 8
5, 4 8 4
5, 5 4 8
5, 6 8 4
5, 7 4 8
5, 8 8 4
5, 9 4 8
5, 10 8 4
5, 11 4 8
5, 12 8 4
5, 13 4 8
5, 14 8 4
5, 15 4 8
5, 16 8 4
HOT SPARE COVERAGE:
The following arrays are not protected: None - All arrays are protected
Total hot spare drives: 3
Standby: 3
In use: 0
Standby drive at enclosure 5, slot 16 (Fibre, 558.912 GB)
Protects the following arrays: RG3, RG1, RG2, RG4, RG5, RG6, RG7, RG8
Standby drive at enclosure 2, slot 11 (Fibre, 558.912 GB)
Protects the following arrays: RG3, RG1, RG2, RG4, RG5, RG6, RG7, RG8
Standby drive at enclosure 1, slot 16 (Fibre, 558.912 GB)
Protects the following arrays: RG3, RG1, RG2, RG4, RG5, RG6, RG7, RG8
DETAILS
Drive at Enclosure 0, Slot 1
Status: Optimal
Mode: Assigned
Raw capacity: 558.912 GB
Usable capacity: 558.412 GB
World-wide identifier: 20:00:b4:52:53:57:b6:25:00:00:00:00:00:00:00:00
Associated array: RG1
Port Channel ID
0 1 0/0xEF
1 5 0/0xEF
Media type: Hard Disk Drive
Interface type: Fibre Channel
Drive path redundancy: OK
Security Capable: No
Secure: No
Read/write accessible: Yes
Drive security key identifier: Not Applicable
Speed: 15,000 RPM
Current data rate: 4 Gbps
Product ID: ST3600057FC F
Drive Firmware Version: B9A4
Serial number: 6SL1BP4T0000B147KZ7T
Manufacturer: IBM-SSG
Date of manufacture: 2011 Jul 4
Drive at Enclosure 0, Slot 2
Status: Optimal
Mode: Assigned
Raw capacity: 558.912 GB
Usable capacity: 558.412 GB
World-wide identifier: 20:00:b4:52:53:ab:ae:74:00:00:00:00:00:00:00:00
Associated array: RG1
Port Channel ID
0 5 1/0xE8
1 1 1/0xE8
Media type: Hard Disk Drive
Interface type: Fibre Channel
Drive path redundancy: OK
Security Capable: No
Secure: No
Read/write accessible: Yes
Drive security key identifier: Not Applicable
Speed: 15,000 RPM
Current data rate: 4 Gbps
Product ID: ST3600057FC F
Drive Firmware Version: B9A4
Serial number: 6SL7YS8L0000B4250CDP
Manufacturer: IBM-SSG
Date of manufacture: 2014 Feb 10
Drive at Enclosure 0, Slot 3
Status: Optimal
Mode: Assigned
Raw capacity: 558.912 GB
Usable capacity: 558.412 GB
World-wide identifier: 20:00:b4:52:53:5a:35:0d:00:00:00:00:00:00:00:00
Associated array: RG1
Port Channel ID
0 1 2/0xE4
1 5 2/0xE4
Media type: Hard Disk Drive
Interface type: Fibre Channel
Drive path redundancy: OK
Security Capable: No
Secure: No
Read/write accessible: Yes
Drive security key identifier: Not Applicable
Speed: 15,000 RPM
Current data rate: 4 Gbps
Product ID: ST3600057FC F
Drive Firmware Version: B9A4
Serial number: 6SL1HTM50000B148Q5BN
Manufacturer: IBM-SSG
Date of manufacture: 2011 Jul 16
Drive at Enclosure 0, Slot 4
Status: Optimal
Mode: Assigned
Raw capacity: 558.912 GB
Usable capacity: 558.412 GB
World-wide identifier: 20:00:b4:52:53:57:b5:db:00:00:00:00:00:00:00:00 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end