import re
regex = re.compile((r"<div[^>]*id=\"THIS\"[^>]*>(.*?)(</div>)+?\n"), flags=re.DOTALL)
test_str = ("<div class=\"viewport viewport_h\" style = \"overflow: hidden;\" >\n"
" <div id=\"THIS\" class=\"overview overview_h\">\n"
" <ul>\n"
" <li>some txt to be captured</li>\n"
" <li>some txt to be captured</li>\n"
" <li>some txt to be captured</li>\n"
" </ul>\n"
" <div>\n"
" \" some text to be captured\"\n"
" </div>\n"
" </div>\n"
"</div>\n"
"\"some text not to be captured\"\n"
"</div>\n"
"<div class=\"scrollbar_h\">\n"
"<div class=\"track_h\"></div>")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")