re = /<div[^>]*id="THIS"[^>]*>(.*?)(<\/div>)+?
/
str = '<div class="viewport viewport_h" style = "overflow: hidden;" >
<div id="THIS" class="overview overview_h">
<ul>
<li>some txt to be captured</li>
<li>some txt to be captured</li>
<li>some txt to be captured</li>
</ul>
<div>
" some text to be captured"
</div>
</div>
</div>
"some text not to be captured"
</div>
<div class="scrollbar_h">
<div class="track_h"></div>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end