$re = '/\P{L}+/u';
$str = 'Some-string string here!';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;