import re
regex = re.compile(r"\P{L}+", flags=re.UNICODE)
test_str = "Some-string string here!"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)