using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(A|D)?R?(B|C|E|F)?(G[12]?)?L?S?(M[12]?)?";
string input = @"ARFLSM2Z";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}