package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(A|D)?R?(B|C|E|F)?(G[12]?)?L?S?(M[12]?)?`)
var str = `ARFLSM2Z`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}